关于Apache HTTP Server越界读取漏洞(CVE-2023-31122)的预警提示

发布者:jsut发布时间:2023-11-01浏览次数:10

一、漏洞详情

Apache HTTP ServerApache软件基金会的一个开放源代码的网页服务器,由于其具有跨平台性和安全性,被广泛使用,它是最流行的Web服务器端软件之一。

近日,监测到Apache HTTP Server中修复了一个越界读取漏洞(CVE-2023-31122)。该漏洞存在于Apache HTTP Servermod_macro模块中,由于在处理超长的宏时,不会添加空字节终止符,导致越界读取,从而导致崩溃。

建议受影响用户做好资产自查以及预防工作,以免遭受黑客攻击。

二、影响范围

Apache HTTP Server <= 2.4.57

三、修复建议

目前该漏洞已经修复,受影响用户可升级到Apache HTTP Server 2.4.58